Windows Server 2016 – Application Errors after a P2V conversion Event ID 1000 Error

After converting a Physical server to a VM, I got a lot of Application Errors 1000.

Looking at the details it was relating to, amongst others, HP related drivers and software

Example : This error shows it is trying to reach a Tape device which is not present in a VM…

image

SOLUTION :

First uninstall all hardware drivers that are not needed in the new VM.

1. Open CMD with admin privileges and run this command

set devmgr_show_nonpresent_devices=1

2. Next run this command

devmgmt.msc

And go to VIEW, select SHOW HIDDEN DEVICES

image


3. Make backup of your VM

Before going to next step MAKE SURE you have a good backup of the current SYSTEM STATE

4. Expanded list

Look at all the GREYED out devices and UNINSTALL these Software and Drives

image

5. Uninstall COM Objects

From the Event Viewer Error I could see we where dealing with a COM related DLL

Use WBEMTest.exe to investigate if the COM Object is still in use.

image

In my case I was sure it would not be needed since the HW was not available anymore

Look for the COM DLL : HPWMITape.dll


image

Run the uninstall command :

regsvr32 /u HPWMITape.dll

Enjoy !

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: